Google Voice Greeting Playback Problem with Firefox and Flashblock

Just debugged a problem which for which there seemed to be no solutions posted on the web already. So in case you (or I, should I forget 🙂 ) run into this, here it is:

Was trying to play back Google Voice greetings on my Linux Mint LMDE system today. I selected the proper greeting and pressed the play button, but nothing happened.

Thinking this was some sound complication with my recent LMDE update pack 8, I spent some time poking around my alsamixer and pulseaudio settings and nothing seemed amiss. Tried googling the web for others with the problem but nothing direct came up… but something triggered me to think about what they used to accomplish this playback within a browser window and I thought… “flash!”.

I had recently installed the Firefox extension Flashblock, which disables and replaces flash entities with a little symbol you can click on to enable them selectively (no more annoying ads playing on web pages and slowing down page loads!). The problem was that the GV greetings page was using flash, but the indication of it being blocked was not showing – there was no symbol to click on.

So I went into the Firefox extensions settings dialog for Flashblock and whitelisted and then went back to try playing the greeting – presto! we have sound!

This entry was posted in Computer, Firefox and tagged , , , . Bookmark the permalink.

One Response to Google Voice Greeting Playback Problem with Firefox and Flashblock

  1. John says:

    Thank you, thank you for posting this solution. You solved my GVoice greeting problem.
    As a workaround I had to use IE whenever I wanted to playback my greeting but now I can use Firefox.

Leave a Reply

Your email address will not be published. Required fields are marked *